|
Graham Dumpleton
graham.dumpleton at gmail.com
Thu Aug 16 18:03:53 EDT 2007
So everyone on the mailing list knows, problem solved. See below. My question now is at what point did Python 2.5 get installed, apparently as Administrator? Did you subsequently uninstall it or is it still on your system somewhere? What might have also worked is if you uninstalled Python 2.4, ensuring user registry entries were cleaned up and then reinstall Python 2.4 as Administrator. Thanks for the feedback, slowly each bit of information we get helps to clarify how some peoples systems end up in this state. BTW, the configuration for this mailing list means that you need to use reply-all for response to go back to the mailing list. Graham On 16/08/07, Jacob Carlsson <jagge_90 at hotmail.com> wrote: > I solved the problem! Now it shows /mpinfo!! > > And i'll tell you how and why. > > I thought about some of the things you wrote in the previous email and i > rememberd: did i check if the python registry file ALSO existed in: > [HKEY_LOCAL_MACHINE\SOFTWARE\Python\PythonCore\2.4] ? > > The answer was no, i only checked HKEY_CURRENT_USER. So i checked if the > registry key existed in HKEY_LOCAL_MACHINE and it didnt! So i went to: > http://www.modpython.org/pipermail/mod_python/2006-September/021979.html > as you have told many users with my problem and i just changed all "2.5" to > "2.4" since im runing python 2.4. I ran the .reg file and restarted my > apache and localhost/mpinfo worked. It shows no errors and seem to show the > correct information. > > Now lets see if i can install Trac without any more troubles with > mod_python.. Hehe. > > Thank you for you excellent help and really fast answers! :) > > Best Regards Jacob Carlsson > > > >From: "Graham Dumpleton" <graham.dumpleton at gmail.com> > >To: "Jacob Carlsson" <jagge_90 at hotmail.com> > >CC: mod_python <mod_python at modpython.org> > >Subject: Re: [mod_python] Apache wont load/start... > >Date: Thu, 16 Aug 2007 21:29:04 +1000 > > > >On 16/08/07, Jacob Carlsson <jagge_90 at hotmail.com> wrote: > > > Hello! > > > > > > Okey. Im going to give some more detaild information. > > > > > > OS: Windows XP SP2 > > > PYTHON: 2.4.4 > > > MOD_PYTHON: mod_python-3.3.1.win32-py2.4-Apache2.0 > > > APACHE: Apache 2.0.59 (yes, its from a installer i didnt compile it > >myself) > > > WHY DO I WANT MOD_PYTHON: To install the project management tool Trac > > > > > > FIRST PROBLEM: > > > Now i had Apache 2.2, mod_python-3.3.1.win32-py2.4-Apache2.2, python 2.4 > > > installed. > > > Everytime i entered "LoadModule python_module modules/mod_python.so" my > > > apache wouldnt start. There was no error specified in the apache monitor > > > only said "Error", and there was no special error specified in apcahes > >Error > > > log either, not any "couldnt find/load module" or anything. > > > >Did you run Apache installer as Administrator? > > > >How are you starting Apache? Are you starting it as yourself directly, > >or as an Apache service? > > > > > HOW DID I SOLVE THE FIRST PROBLEM: > > > I really did not solve it, or maybe? First i couldnt even launch apache > > > 2.0.59 when adding "LoadModule ...." but then i thought, why not try > > > downgrading and make clean install once more and so i did. I unistalled > > > apache 2.2 and mod_python installed clean apache 2.0.59 and mod_python, > > > restarted my computer and it worked. Now i could load the module without > > > apache screaming about a Error. Though i directly ran into next problem > >but > > > at least i got somewhere. > > > So note that BEFORE i restarted my computer i also added: > > > > > > Well i simply added some paths to the PATH variable (Right click your > >"My > > > computer" -> Properties -> Advanced -> Enviorment Variables -> find PATH > >i > > > list -> add directorys where python is installed) > > > > > > I never tried these settings with Apache 2.2 since i didnt understand > >that > > > restarting was needed. > > > Also maybe this didnt solve my problem, maybe it was something else? And > > > thats just exaclty the reason why im staying at 2.0.59 now when i got it > > > working instead of going back to 2.2 and getting that error again. > > > > > > SECOND PROBLEM: > > > Well, now i got apache 2.0.59, mod_python 3.3.1 read my settings on top > >of > > > the mail for more detaild information about my system as it is now. Now > >i > > > can run apache when LoadModule is uncommented in httpd.conf but i cant > >use |